CVE-2017-2896

Published: 20 November 2017

An exploitable out-of-bounds write vulnerability exists in the xls_mergedCells function of libxls 1.4. . A specially crafted XLS file can cause a memory corruption resulting in remote code execution. An attacker can send malicious XLS file to trigger this vulnerability.

Priority

Medium

CVSS 3 base score: 7.8

Status

Package Release Status
r-cran-readxl
Launchpad, Ubuntu, Debian
Upstream
Released (1.0.0-2, 0.1.1-1+deb9u1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1.0.0-2)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.0.0-2)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1.0.0-2)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist