CVE-2017-2295

Published: 25 May 2017

Versions of Puppet prior to 4.10.1 will deserialize data off the wire (from the agent to the server, in this case) with a attacker-specified format. This could be used to force YAML deserialization in an unsafe manner, which would lead to remote code execution. This change constrains the format of data on the wire to PSON or safely decoded YAML.

Priority

Medium

CVSS 3 base score: 8.2

Status

Package Release Status
puppet
Launchpad, Ubuntu, Debian
Upstream
Released (4.8.2-5)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(4.8.2-5ubuntu1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(4.8.2-5ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(4.8.2-5ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.8.2-5ubuntu1)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (3.4.3-1ubuntu1.2)
Patches:
Upstream: https://github.com/puppetlabs/puppet/commit/06d8c51367ca932b9da5d9b01958cfc0adf0f2ea