CVE-2016-9920

Published: 08 December 2016

steps/mail/sendmail.inc in Roundcube before 1.1.7 and 1.2.x before 1.2.3, when no SMTP server is configured and the sendmail program is enabled, does not properly restrict the use of custom envelope-from addresses on the sendmail command line, which allows remote authenticated users to execute arbitrary code via a modified HTTP request that sends a crafted e-mail message.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
roundcube
Launchpad, Ubuntu, Debian
Upstream
Released (1.2.3+dfsg.1-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1.3.6+dfsg.1-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.3.6+dfsg.1-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1.3.6+dfsg.1-1)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected)
Patches:
Other: https://github.com/roundcube/roundcubemail/commit/f84233785ddeed01445fc855f3ae1e8a62f167e1