CVE-2016-5420

Published: 03 August 2016

curl and libcurl before 7.50.1 do not check the client certificate when choosing the TLS connection to reuse, which might allow remote attackers to hijack the authentication of the connection by leveraging a previously created connection with a different client certificate.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
curl
Launchpad, Ubuntu, Debian
Upstream
Released (7.50.1-1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (7.47.0-1ubuntu2.1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (7.35.0-1ubuntu2.8)
Patches:
Upstream: https://curl.haxx.se/CVE-2016-5420.patch

Notes

AuthorNote
seth-arnold
when built against NSS another patch is needed, see
http://www.openwall.com/lists/oss-security/2016/09/05/1 for information
http://www.openwall.com/lists/oss-security/2016/09/05/7

References