CVE-2015-8384

Published: 01 December 2015

PCRE before 8.38 mishandles the /(?J)(?'d'(?'d'\g{d}))/ pattern and related patterns with certain recursive back references, which allows remote attackers to cause a denial of service (buffer overflow) or possibly have unspecified other impact via a crafted regular expression, as demonstrated by a JavaScript RegExp object encountered by Konqueror, a related issue to CVE-2015-8392 and CVE-2015-8395.

Priority

Low

Status

Package Release Status
pcre2
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(issue affects PCRE3 only)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(issue affects PCRE3 only)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

pcre3
Launchpad, Ubuntu, Debian
Upstream
Released (2:8.35-7.2)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(2:8.38-3)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(2:8.38-3)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(code not present)
Patches:
Upstream: http://vcs.pcre.org/pcre?view=revision&revision=1558

Notes

AuthorNote
tyhicks
Issue affects PCRE3 only
Marking 'low' since it requires PCRE to operate on untrusted regular
expressions which is not very likely
Per Debian, the fix for CVE-2015-3210 also fixes this issue
mdeslaur
introduced in 8.34

CVE-2015-2325_CVE-2015-2326_CVE-2015-3210_CVE-2015-5073.patch
in jessie

References

Bugs