CVE-2015-8380

Published: 01 December 2015

The pcre_exec function in pcre_exec.c in PCRE before 8.38 mishandles a // pattern with a \01 string, which allows remote attackers to cause a denial of service (heap-based buffer overflow) or possibly have unspecified other impact via a crafted regular expression, as demonstrated by a JavaScript RegExp object encountered by Konqueror.

Priority

Low

Status

Package Release Status
pcre2
Launchpad, Ubuntu, Debian
Upstream Not vulnerable

Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

pcre3
Launchpad, Ubuntu, Debian
Upstream
Released (8.38)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(2:8.38-3)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (1:8.31-2ubuntu2.2)
Patches:
Upstream: http://vcs.pcre.org/pcre?view=revision&revision=1565