Your submission was sent successfully! Close

CVE-2015-7499

Published: 26 November 2015

Heap-based buffer overflow in the xmlGROW function in parser.c in libxml2 before 2.9.3 allows context-dependent attackers to obtain sensitive process memory information via unspecified vectors.

Notes

AuthorNote
mdeslaur
USN-2834-1 was missing part of the fix for this issue:
See lp bug
Priority

Low

Status

Package Release Status
libxml2
Launchpad, Ubuntu, Debian
precise
Released (2.7.8.dfsg-5.1ubuntu4.13)
trusty
Released (2.9.1+dfsg1-3ubuntu4.6)
upstream
Released (2.9.3)
vivid
Released (2.9.2+dfsg1-3ubuntu0.2)
wily
Released (2.9.2+zdfsg1-4ubuntu0.2)
Patches:
upstream: https://git.gnome.org/browse/libxml2/commit/?id=28cd9cb747a94483f4aea7f0968d202c20bb4cfc
upstream: https://git.gnome.org/browse/libxml2/commit/?id=35bcb1d758ed70aa7b257c9c3b3ff55e54e3d0da
upstream: https://git.gnome.org/browse/libxml2/commit/?id=ce0b0d0d81fdbb5f722a890432b52d363e4de57b