CVE-2015-5607

Published: 20 September 2017

Cross-site request forgery in the REST API in IPython 2 and 3.

Priority

Low

CVSS 3 base score: 8.8

Status

Package Release Status
ipython
Launchpad, Ubuntu, Debian
Upstream
Released (2.4.1-1, 5.1.0-3)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(5.5.0-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(5.5.0-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(5.5.0-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(5.5.0-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(5.5.0-1)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(2.4.1-1)
Ubuntu 14.04 ESM (Trusty Tahr) Needed

Patches:
Upstream: https://github.com/ipython/ipython/commit/a05fe052a18810e92d9be8c1185952c13fe4e5b0 (2.x)
Upstream: https://github.com/ipython/ipython/commit/1415a9710407e7c14900531813c15ba6165f0816 (3.x)