Your submission was sent successfully! Close

CVE-2015-5330

Published: 16 December 2015

ldb before 1.1.24, as used in the AD LDAP server in Samba 4.x before 4.1.22, 4.2.x before 4.2.7, and 4.3.x before 4.3.3, mishandles string lengths, which allows remote attackers to obtain sensitive information from daemon heap memory by sending crafted packets and then reading (1) an error message or (2) a database value.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
ldb
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 16.04 ESM (Xenial Xerus)
Released (2:1.1.24-1ubuntu1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (1:1.1.16-1ubuntu0.1)
samba
Launchpad, Ubuntu, Debian
Upstream
Released (4.3.3,4.2.7,4.1.22)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (2:4.3.3+dfsg-1ubuntu1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (2:4.1.6+dfsg-1ubuntu2.14.04.11)
Patches:
Upstream: https://git.samba.org/?p=samba.git;a=commit;h=1aef718f3cc175d90d40202a333042a38ba382b1 (4.1)
Upstream: https://git.samba.org/?p=samba.git;a=commit;h=7bcac237656083e67bbac9b50be9b319bb2d7eb8 (4.1)
Upstream: https://git.samba.org/?p=samba.git;a=commit;h=5f3c7541c2f10ac2174538288f6569af587d69f0 (4.1)
Upstream: https://git.samba.org/?p=samba.git;a=commit;h=a561ae6294fa926bf3a15b9aaf3d18d25d5e971f (4.1)
Upstream: https://git.samba.org/?p=samba.git;a=commit;h=f07626d0297ed6bd21623409e1ea1ae1138d23a8 (4.1)
Upstream: https://git.samba.org/?p=samba.git;a=commit;h=83f1d39cd9ab9b8b548602f9ee806a994fca9d0c (4.1)
samba4
Launchpad, Ubuntu, Debian
Upstream
Released (4.3.3,4.2.7,4.1.22)
Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist