Your submission was sent successfully! Close

CVE-2015-4145

Published: 1 June 2015

The EAP-pwd server and peer implementation in hostapd and wpa_supplicant 1.0 through 2.4 does not validate a fragment is already being processed, which allows remote attackers to cause a denial of service (memory leak) via a crafted message.

Priority

Medium

Status

Package Release Status
hostapd
Launchpad, Ubuntu, Debian
precise Not vulnerable
(code not present)
trusty Does not exist

upstream Pending
(2.5)
utopic Does not exist

vivid Does not exist

wpa
Launchpad, Ubuntu, Debian
precise Does not exist

trusty
Released (2.1-0ubuntu1.3)
upstream Pending
(2.5)
utopic
Released (2.1-0ubuntu4.2)
vivid
Released (2.1-0ubuntu7.2)
wpasupplicant
Launchpad, Ubuntu, Debian
precise Not vulnerable
(code not present)
trusty Does not exist

upstream Pending
(2.5)
utopic Does not exist

vivid Does not exist