CVE-2015-2695

Published: 08 November 2015

lib/gssapi/spnego/spnego_mech.c in MIT Kerberos 5 (aka krb5) before 1.14 relies on an inappropriate context handle, which allows remote attackers to cause a denial of service (incorrect pointer read and process crash) via a crafted SPNEGO packet that is mishandled during a gss_inquire_context call.

Priority

Medium

Status

Package Release Status
krb5
Launchpad, Ubuntu, Debian
Upstream
Released (1.13.2+dfsg-3)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(1.13.2+dfsg-3)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (1.12+dfsg-2ubuntu5.2)
Patches:
Upstream: https://github.com/krb5/krb5/commit/b51b33f2bc5d1497ddf5bd107f791c101695000d
Upstream: https://github.com/krb5/krb5/commit/222b09f6e2f536354555f2a0dedfe29fc10c01d6 (regression fix)