Your submission was sent successfully! Close

CVE-2014-3506

Published: 07 August 2014

d1_both.c in the DTLS implementation in OpenSSL 0.9.8 before 0.9.8zb, 1.0.0 before 1.0.0n, and 1.0.1 before 1.0.1i allows remote attackers to cause a denial of service (memory consumption) via crafted DTLS handshake messages that trigger memory allocations corresponding to large length values.

Priority

Medium

Status

Package Release Status
openssl
Launchpad, Ubuntu, Debian
Upstream
Released (0.9.8zb,1.0.1i)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1.0.1f-1ubuntu7)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (1.0.1f-1ubuntu7)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (1.0.1f-1ubuntu2.5)
Patches:
Upstream: https://git.openssl.org/gitweb/?p=openssl.git;a=commit;h=fc7804ec392fcf8051abe6bc9da9108744d2ae35 (1.0.1)
Upstream: https://git.openssl.org/gitweb/?p=openssl.git;a=commit;h=338a5e7e5458edf4cf754fd831a451fb4b57d180 (0.9.8)
openssl098
Launchpad, Ubuntu, Debian
Upstream
Released (0.9.8zb)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)