Your submission was sent successfully! Close

CVE-2012-4562

Published: 20 November 2012

Multiple integer overflows in libssh before 0.5.3 allow remote attackers to cause a denial of service (infinite loop or crash) and possibly execute arbitrary code via unspecified vectors, which triggers a buffer overflow, infinite loop, or possibly some other unspecified vulnerabilities.

Priority

Medium

Status

Package Release Status
libssh
Launchpad, Ubuntu, Debian
hardy Ignored
(reached end-of-life)
lucid
Released (0.4.2-1ubuntu1.1)
oneiric
Released (0.5.2-1ubuntu0.11.10.1)
precise
Released (0.5.2-1ubuntu0.12.04.1)
quantal
Released (0.5.2-1ubuntu0.12.10.1)
upstream
Released (0.5.3-1)
Patches:
upstream: http://git.libssh.org/projects/libssh.git/commit/?h=v0-5&id=8489521c0d7a9d1336b23a4a64e5df2d0f3ba57a
upstream: http://git.libssh.org/projects/libssh.git/commit/?h=v0-5&id=db81310d719878cc04b23e4033fbe19fa0b1f8a3
upstream: http://git.libssh.org/projects/libssh.git/commit/?h=v0-5&id=1699adfa036ffc66c62fdbb784610445cbebfc6e
upstream: http://git.libssh.org/projects/libssh.git/commit/?h=v0-5&id=e3d9501b31a11b427afe1cc1cba5208adc2c3c39