Your submission was sent successfully! Close

CVE-2010-4706

Published: 24 January 2011

The pam_sm_close_session function in pam_xauth.c in the pam_xauth module in Linux-PAM (aka pam) 1.1.2 and earlier does not properly handle a failure to determine a certain target uid, which might allow local users to delete unintended files by executing a program that relies on the pam_xauth PAM check.

Priority

Low

Status

Package Release Status
pam
Launchpad, Ubuntu, Debian
dapper Ignored
(reached end-of-life)
hardy
Released (0.99.7.1-5ubuntu6.3)
karmic Ignored
(reached end-of-life)
lucid
Released (1.1.1-2ubuntu5.2)
maverick
Released (1.1.1-4ubuntu2.2)
natty
Released (1.1.2-2ubuntu8.2)
upstream
Released (1.1.3)

Notes

AuthorNote
sbeattie
pam_xauth.so not enabled in default install
mdeslaur
introduced by this bugfix: http://git.altlinux.org/people/ldv/packages/?p=pam.git;a=commitdiff;h=60530da87ddd4ce280fbd5cae182dc7ac3b1a154#patch2
see complete patch list in CVE-2010-3435

References

Bugs