CVE-2010-4555

Published: 14 July 2011

Multiple cross-site scripting (XSS) vulnerabilities in SquirrelMail 1.4.21 and earlier allow remote attackers to inject arbitrary web script or HTML via vectors involving (1) drop-down selection lists, (2) the > (greater than) character in the SquirrelSpell spellchecking plugin, and (3) errors associated with the Index Order (aka options_order) page.

Priority

Low

Status

Package Release Status
squirrelmail
Launchpad, Ubuntu, Debian
Upstream
Released (1.4.22)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(2:1.4.22-1)
Ubuntu 12.04 ESM (Precise Pangolin) Not vulnerable
(2:1.4.22-1)
Patches:
Upstream: http://squirrelmail.svn.sourceforge.net/viewvc/squirrelmail?view=revision&revision=14119