Your submission was sent successfully! Close

CVE-2010-3430

Published: 24 January 2011

The privilege-dropping implementation in the (1) pam_env and (2) pam_mail modules in Linux-PAM (aka pam) 1.1.2 does not perform the required setfsgid and setgroups system calls, which might allow local users to obtain sensitive information by leveraging unintended group permissions, as demonstrated by a symlink attack on the .pam_environment file in a user's home directory. NOTE: this vulnerability exists because of an incomplete fix for CVE-2010-3435.

Priority

Medium

Status

Package Release Status
pam
Launchpad, Ubuntu, Debian
dapper Ignored
(reached end-of-life)
hardy
Released (0.99.7.1-5ubuntu6.3)
karmic Ignored
(reached end-of-life)
lucid
Released (1.1.1-2ubuntu5.2)
maverick
Released (1.1.1-4ubuntu2.2)
natty
Released (1.1.2-2ubuntu8.2)
upstream
Released (1.1.3)
Patches:
upstream: http://git.altlinux.org/people/ldv/packages/?p=pam.git;a=commit;h=843807a3a90f52e7538be756616510730a24739a