CVE-2010-2761

Published: 06 December 2010

The multipart_init function in (1) CGI.pm before 3.50 and (2) Simple.pm in CGI::Simple 1.112 and earlier uses a hardcoded value of the MIME boundary string in multipart/x-mixed-replace content, which allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via crafted input that contains this value, a different vulnerability than CVE-2010-3172.

Priority

Medium

Status

Package Release Status
libcgi-pm-perl
Launchpad, Ubuntu, Debian
Upstream
Released (3.50-1)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(3.50-1)
Patches:
Upstream: https://github.com/AndyA/CGI--Simple/commit/e4942b871a26c1317a175a91ebb7262eea59b380
libcgi-simple-perl
Launchpad, Ubuntu, Debian
Upstream
Released (1.111-2)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(1.111-2)
perl
Launchpad, Ubuntu, Debian
Upstream
Released (5.10.1-17)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(5.10.1-17ubuntu1)