Your submission was sent successfully! Close

CVE-2010-1634

Published: 27 May 2010

Multiple integer overflows in audioop.c in the audioop module in Python 2.6, 2.7, 3.1, and 3.2 allow context-dependent attackers to cause a denial of service (application crash) via a large fragment, as demonstrated by a call to audioop.lin2lin with a long string in the first argument, leading to a buffer overflow. NOTE: this vulnerability exists because of an incorrect fix for CVE-2008-3143.5.

Priority

Low

Status

Package Release Status
python2.4
Launchpad, Ubuntu, Debian
dapper Ignored
(reached end-of-life)
hardy
Released (2.4.5-1ubuntu4.4)
jaunty Ignored
(reached end-of-life)
karmic Ignored
(reached end-of-life)
lucid Does not exist

maverick Does not exist

natty Does not exist

oneiric Does not exist

precise Does not exist

quantal Does not exist

upstream Needs triage

python2.5
Launchpad, Ubuntu, Debian
dapper Does not exist

hardy
Released (2.5.2-2ubuntu6.2)
jaunty Ignored
(reached end-of-life)
karmic Ignored
(reached end-of-life)
lucid Does not exist

maverick Does not exist

natty Does not exist

oneiric Does not exist

precise Does not exist

quantal Does not exist

upstream Needs triage

Patches:
upstream: http://hg.python.org/cpython/rev/488dbe262f68/ (pt1)
upstream: http://hg.python.org/cpython/rev/c0dd33a5adbe/ (pt2)




python2.6
Launchpad, Ubuntu, Debian
dapper Does not exist

hardy Does not exist

jaunty Ignored
(reached end-of-life)
karmic Ignored
(reached end-of-life)
lucid
Released (2.6.5-1ubuntu6.1)
maverick Not vulnerable
(2.6.6-5ubuntu1)
natty Not vulnerable
(2.6.6-5ubuntu1)
oneiric Not vulnerable
(2.6.6-5ubuntu1)
precise Does not exist

quantal Does not exist

upstream
Released (2.6.6-1)
Patches:


upstream: http://hg.python.org/cpython/rev/7f5a571b1ecb/ (pt1)
upstream: http://hg.python.org/cpython/rev/0ac11db5fc96/ (pt2)


python2.7
Launchpad, Ubuntu, Debian
hardy Does not exist

lucid Does not exist

maverick Not vulnerable
(2.7-6)
natty Not vulnerable

oneiric Not vulnerable

precise Not vulnerable

quantal Not vulnerable

upstream
Released (2.7-1)
python3.1
Launchpad, Ubuntu, Debian
hardy Does not exist

lucid
Released (3.1.2-0ubuntu3.2)
natty Not vulnerable
(3.1.3-1ubuntu1.1)
oneiric Does not exist

precise Does not exist

quantal Does not exist

upstream
Released (3.1.3-1)
Patches:




upstream: http://hg.python.org/cpython/rev/20ae83821ef0 (pt1)
upstream: http://hg.python.org/cpython/rev/011940baefb0 (pt2)
python3.2
Launchpad, Ubuntu, Debian
hardy Does not exist

lucid Does not exist

natty Not vulnerable
(3.2-1ubuntu1)
oneiric Not vulnerable

precise Not vulnerable

quantal Not vulnerable

upstream
Released (3.2)