CVE-2008-3657

Published: 12 August 2008

The dl module in Ruby 1.8.5 and earlier, 1.8.6 through 1.8.6-p286, 1.8.7 through 1.8.7-p71, and 1.9 through r18423 does not check "taintness" of inputs, which allows context-dependent attackers to bypass safe levels and execute dangerous functions by accessing a library using DL.dlopen.

Priority

Medium

Status

Package Release Status
ruby1.8
Launchpad, Ubuntu, Debian
Upstream
Released (1.8.7.72-1)
ruby1.9
Launchpad, Ubuntu, Debian
Upstream
Released (1.9.0.2-7)