Still running Ubuntu 14.04?

Learn how to maintain ongoing security compliance for your 14.04 systems.

Watch the webinar

As Ubuntu 14.04 LTS Trusty Tahr transitions from Standard Security Maintenance, it is encouraged for users and organisations to upgrade to the latest LTS release to ensure systems remain patched against security vulnerabilities.

For organisations operating systems with longer production lifespans or development cycles, and for those requiring GDPR compliance across legacy deployments, Extended Security Maintenance (ESM) provides ongoing critical and important security patches for 14.04.

To learn more about your Ubuntu upgrade options and how to ensure ongoing security and compliance of your 14.04 LTS systems, watch our webinar with Ubuntu Security Manager, Joe McManus, and talk with our team to start planning.