USN-830-1: OpenSSL vulnerability

14 September 2009

OpenSSL vulnerability

Releases

Packages

Details

Dan Kaminsky discovered OpenSSL would still accept certificates with MD2
hash signatures. As a result, an attacker could potentially create a
malicious trusted certificate to impersonate another site. This update
handles this issue by completely disabling MD2 for certificate validation.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 9.04
Ubuntu 8.10
Ubuntu 8.04
Ubuntu 6.06

After a standard system upgrade you need to reboot your computer to
effect the necessary changes.

References

Related notices

  • USN-809-1: gnutls26, libgnutls26, libgnutls13, libgnutls12, gnutls12, gnutls13
  • USN-810-1: libnss3-1d, nss
  • USN-859-1: openjdk-6, openjdk-6-jre, icedtea6-plugin