Your submission was sent successfully! Close

USN-5576-1: Twisted vulnerability

24 August 2022

Twisted could be made to expose sensitive information over the network.

Releases

Packages

  • twisted - Event-based framework for internet applications

Details

It was discovered that Twisted incorrectly parsed some types of HTTP requests
in its web server implementation. In certain proxy or multi-server
configurations, a remote attacker could craft malicious HTTP requests in order
to obtain sensitive information.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 22.04

In general, a standard system update will make all the necessary changes.

References