Your submission was sent successfully! Close

USN-5021-2: curl vulnerability

20 January 2022

curl could be made to expose sensitive information if it received a specially crafted input.

Releases

Packages

  • curl - HTTP, HTTPS, and FTP client and client libraries

Details

USN-5021-1 fixed vulnerabilities in curl. This update provides
the corresponding updates for Ubuntu 16.04 ESM.

Original advisory details:

Harry Sintonen and Tomas Hoger discovered that curl incorrectly handled
TELNET connections when the -t option was used on the command line.
Uninitialized data possibly containing sensitive information could be sent
to the remote server, contrary to expectations. (CVE-2021-22898,
CVE-2021-22925)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 16.04

In general, a standard system update will make all the necessary changes.

Related notices

  • USN-5021-1: libcurl4-nss-dev, libcurl4-doc, libcurl4-openssl-dev, libcurl4, libcurl4-gnutls-dev, libcurl3-nss, curl, libcurl3-gnutls