USN-4881-1: containerd vulnerability

17 March 2021

The system could be made to expose sensitive information.

Releases

Packages

Details

It was discovered that containerd incorrectly handled certain environment
variables. Contrary to expectations, a container could receive environment
variables defined for a different container, possibly containing sensitive
information.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 20.10
Ubuntu 20.04

After a standard system update you need to restart containerd to make
all the necessary changes.

References