Your submission was sent successfully! Close

USN-440-1: MySQL vulnerability

22 March 2007

MySQL vulnerability

Releases

Details

Stefan Streichbier and B. Mueller of SEC Consult discovered that MySQL
subselect queries using "ORDER BY" could be made to crash the MySQL
server. An attacker with access to a MySQL instance could cause an
intermitant denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 6.10
  • mysql-server-5.0 - 5.0.24a-9ubuntu0.1
Ubuntu 6.06
  • mysql-server-5.0 - 5.0.22-0ubuntu6.06.3

In general, a standard system upgrade is sufficient to effect the
necessary changes.

References