USN-4078-1: OpenLDAP vulnerabilities

30 July 2019

Several security issues were fixed in OpenLDAP.

Releases

Packages

Details

It was discovered that OpenLDAP incorrectly handled rootDN delegation. A
database administrator could use this issue to request authorization as an
identity from another database, contrary to expectations. (CVE-2019-13057)

It was discovered that OpenLDAP incorrectly handled SASL authentication and
session encryption. After a first SASL bind was completed, it was possible
to obtain access by performing simple binds, contrary to expectations.
(CVE-2019-13565)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.04
Ubuntu 18.04
Ubuntu 16.04

In general, a standard system update will make all the necessary changes.

Related notices

  • USN-4078-2: openldap, slapd-smbk5pwd, libldap-2.4-2, slapd, libldap2-dev, ldap-utils