Your submission was sent successfully! Close

USN-3363-1: ImageMagick vulnerabilities

24 July 2017

Several security issues were fixed in ImageMagick.

Releases

Packages

  • imagemagick - Image manipulation programs and library

Details

It was discovered that ImageMagick incorrectly handled certain malformed
image files. If a user or automated system using ImageMagick were tricked
into opening a specially crafted image, an attacker could exploit this to
cause a denial of service or possibly execute code with the privileges of
the user invoking the program.

Related notices

  • USN-3681-1: libmagick++-6.q16hdri-7, libimage-magick-q16-perl, libmagickcore-6.q16hdri-dev, libmagickcore-6.q16-3-extra, libmagickcore-dev, libmagick++-6.q16-dev, imagemagick-6.q16hdri, imagemagick-doc, libmagick++-dev, libmagickcore-6.q16hdri-3-extra, libmagick++-6.q16-5v5, libmagickwand-6.q16hdri-3, libmagickwand5, imagemagick-6.q16, imagemagick-common, libmagickcore5-extra, libmagickcore-6.q16-2, libmagickcore-6-arch-config, imagemagick, libmagickwand-6.q16-2, libmagickcore-6.q16-dev, perlmagick, libmagick++-6.q16hdri-dev, libmagick++-6.q16-7, libmagickwand-6-headers, libmagick++5, libmagickwand-6.q16-3, imagemagick-6-common, libmagick++-6-headers, libimage-magick-q16hdri-perl, libmagickcore5, libmagickcore-6.q16hdri-3, libmagickcore-6.q16-3, libmagickwand-dev, libmagickwand-6.q16hdri-dev, imagemagick-6-doc, libimage-magick-perl, libmagickcore-6-headers, libmagickcore-6.q16-2-extra, libmagickwand-6.q16-dev