Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2022-41318

Published: 23 September 2022

A buffer over-read was discovered in libntlmauth in Squid 2.5 through 5.6. Due to incorrect integer-overflow protection, the SSPI and SMB authentication helpers are vulnerable to reading unintended memory locations. In some configurations, cleartext credentials from these locations are sent to a client. This is fixed in 5.7.

Priority

Medium

Cvss 3 Severity Score

8.6

Score breakdown

Status

Package Release Status
squid
Launchpad, Ubuntu, Debian
bionic Does not exist

focal
Released (4.10-1ubuntu1.7)
jammy
Released (5.2-1ubuntu4.2)
kinetic
Released (5.6-1ubuntu3)
lunar
Released (5.6-1ubuntu3)
mantic
Released (5.6-1ubuntu3)
noble
Released (5.6-1ubuntu3)
trusty Ignored
(end of standard support)
upstream
Released (5.7)
xenial Ignored
(end of standard support)
squid3
Launchpad, Ubuntu, Debian
bionic
Released (3.5.27-1ubuntu1.14)
focal Does not exist

jammy Does not exist

trusty Ignored
(end of standard support)
upstream Needs triage

xenial
Released (3.5.12-1ubuntu7.16+esm3)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)

Severity score breakdown

Parameter Value
Base score 8.6
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Changed
Confidentiality High
Integrity impact None
Availability impact None
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N