Your submission was sent successfully! Close

CVE-2022-1586

Published: 16 May 2022

An out-of-bounds read vulnerability was discovered in the PCRE2 library in the compile_xclass_matchingpath() function of the pcre2_jit_compile.c file. This involves a unicode property matching issue in JIT-compiled regular expressions. The issue occurs because the character was not fully read in case-less matching within JIT.

Priority

Low

CVSS 3 base score: 9.1

Status

Package Release Status
pcre2
Launchpad, Ubuntu, Debian
bionic Needed

focal
Released (10.34-7ubuntu0.1)
impish Ignored
(reached end-of-life)
jammy
Released (10.39-3ubuntu0.1)
upstream
Released (10.40-1)
Patches:
upstream: https://github.com/PCRE2Project/pcre2/commit/50a51cb7e67268e6ad417eb07c9de9bfea5cc55a (pcre2-10.40)
upstream: https://github.com/PCRE2Project/pcre2/commit/d4fa336fbcc388f89095b184ba6d99422cfc676c