CVE-2021-25214

Published: 28 April 2021

In BIND 9.8.5 -> 9.8.8, 9.9.3 -> 9.11.29, 9.12.0 -> 9.16.13, and versions BIND 9.9.3-S1 -> 9.11.29-S1 and 9.16.8-S1 -> 9.16.13-S1 of BIND 9 Supported Preview Edition, as well as release versions 9.17.0 -> 9.17.11 of the BIND 9.17 development branch, when a vulnerable version of named receives a malformed IXFR triggering the flaw described above, the named process will terminate due to a failed assertion the next time the transferred secondary zone is refreshed.

Priority

Medium

Status

Package Release Status
bind9
Launchpad, Ubuntu, Debian
Upstream
Released (9.11.30,9.16.14,9.17.12)
Ubuntu 21.04 (Hirsute Hippo)
Released (1:9.16.8-1ubuntu3.1)
Ubuntu 20.10 (Groovy Gorilla)
Released (1:9.16.6-3ubuntu1.2)
Ubuntu 20.04 LTS (Focal Fossa)
Released (1:9.16.1-0ubuntu2.8)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1:9.11.3+dfsg-1ubuntu1.15)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (1:9.10.3.dfsg.P4-8ubuntu1.19)
Ubuntu 14.04 ESM (Trusty Tahr) Needs triage