CVE-2021-23215

Published: 08 June 2021

An integer overflow leading to a heap-buffer overflow was found in the DwaCompressor of OpenEXR in versions before 3.0.1. An attacker could use this flaw to crash an application compiled with OpenEXR.

Priority

Low

CVSS 3 base score: 5.5

Status

Package Release Status
openexr
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.04 (Hirsute Hippo) Needs triage

Ubuntu 20.10 (Groovy Gorilla) Ignored
(reached end-of-life)
Ubuntu 20.04 LTS (Focal Fossa) Needs triage

Ubuntu 18.04 LTS (Bionic Beaver)
Released (2.2.0-11.1ubuntu1.7)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (2.2.0-10ubuntu2.6+esm1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: https://github.com/AcademySoftwareFoundation/openexr/pull/901/commits/c3e45956dd111482671fb8d88b40022248f783f7