CVE-2020-4033

Published: 22 June 2020

In FreeRDP before version 2.1.2, there is an out of bounds read in RLEDECOMPRESS. All FreeRDP based clients with sessions with color depth < 32 are affected. This is fixed in version 2.1.2.

Priority

Low

CVSS 3 base score: 6.5

Status

Package Release Status
freerdp
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Does not exist

Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 ESM (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

freerdp2
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Not vulnerable
(2.2.0+dfsg1-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(2.2.0+dfsg1-1)
Ubuntu 20.04 LTS (Focal Fossa)
Released (2.2.0+dfsg1-0ubuntu0.20.04.1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2.2.0+dfsg1-0ubuntu0.18.04.1)
Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: https://github.com/FreeRDP/FreeRDP/commit/0a98c450c58ec150e44781c89aa6f8e7e0f571f5

Notes

AuthorNote
mdeslaur
The freerdp package in Ubuntu 16.04 LTS and Ubuntu 18.04 LTS
does not build a server library. This is simply a client
denial of service that has a negligible security impact.

References