CVE-2020-25814

Published: 27 September 2020

In MediaWiki before 1.31.10 and 1.32.x through 1.34.x before 1.34.4, XSS related to jQuery can occur. The attacker creates a message with [javascript:payload xss] and turns it into a jQuery object with mw.message().parse(). The expected result is that the jQuery object does not contain an <a> tag (or it does not have a href attribute, or it's empty, etc.). The actual result is that the object contains an <a href ="javascript... that executes when clicked.

Priority

Medium

CVSS 3 base score: 6.1

Status

Package Release Status
mediawiki
Launchpad, Ubuntu, Debian
Upstream
Released (1:1.35.0-1)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(1:1.35.0-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1:1.35.0-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(1:1.35.0-1)
Ubuntu 20.04 LTS (Focal Fossa) Needs triage

Ubuntu 18.04 LTS (Bionic Beaver) Needs triage

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist