CVE-2020-24916

Published: 09 September 2020

CGI implementation in Yaws web server versions 1.81 to 2.0.7 is vulnerable to OS command injection.

From the Ubuntu security team

It was discovered that Yaws mishandled certain input when running CGI scripts. A remote attacker could use this vulnerability to execute arbitrary commands.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
yaws
Launchpad, Ubuntu, Debian
Upstream
Released (2.0.8+dfsg-1)
Ubuntu 20.10 (Groovy Gorilla) Needed

Ubuntu 20.04 LTS (Focal Fossa) Needed

Ubuntu 18.04 LTS (Bionic Beaver)
Released (2.0.4+dfsg-2ubuntu0.1)
Ubuntu 16.04 LTS (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Ubuntu 12.04 ESM (Precise Pangolin) Does not exist