CVE-2020-22617

Published: 08 October 2021

Ardour v5.12 contains a use-after-free vulnerability in the component ardour/libs/pbd/xml++.cc when using xmlFreeDoc and xmlXPathFreeContext.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
ardour
Launchpad, Ubuntu, Debian
Upstream
Released (1:6.0.0~ds0-1)
Ubuntu 21.10 (Impish Indri) Not vulnerable

Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1:6.6.0+ds0-0ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa)
Released (1:5.12.0-3ubuntu4.1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1:5.12.0-3ubuntu0.1)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(out of standard support)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: https://github.com/Ardour/ardour/commit/96daa4036a425ff3f23a7dfcba57bfb0f942bec6 (6.0-pre1)