CVE-2020-10804

Published: 22 March 2020

In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability was found in retrieval of the current username (in libraries/classes/Server/Privileges.php and libraries/classes/UserPassword.php). A malicious user with access to the server could create a crafted username, and then trick the victim into performing specific actions with that user account (such as editing its privileges).

From the Ubuntu security team

It was discovered that phpMyAdmin failed to sanitize certain input. An attacker could use this vulnerability to execute an SQL injection attack via a specially crafted username.

Priority

Medium

CVSS 3 base score: 8.0

Status

Package Release Status
phpmyadmin
Launchpad, Ubuntu, Debian
Upstream
Released (4:4.9.5+dfsg1-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(4:4.9.5+dfsg1-1ubuntu1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(4:4.9.5+dfsg1-1ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(4:4.9.5+dfsg1-1ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (4:4.6.6-5ubuntu0.5)
Ubuntu 16.04 LTS (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Needed