CVE-2020-10543

Published: 01 June 2020

Perl before 5.30.3 on 32-bit platforms allows a heap-based buffer overflow because nested regular expression quantifiers have an integer overflow. An application written in Perl would only be vulnerable to this flaw if it evaluates regular expressions supplied by the attacker. Evaluating regular expressions in this fashion is known to be dangerous since the regular expression engine does not protect against denial of service attacks in this usage scenario. Additionally, the target system needs a sufficient amount of memory to allocate partial expansions of the nested quantifiers prior to the overflow occurring. This requirement is unlikely to be met on 64bit systems.]

Priority

Low

CVSS 3 base score: 8.2

Status

Package Release Status
perl
Launchpad, Ubuntu, Debian
Upstream
Released (5.28.3,5.30.3)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(5.30.3-4)
Ubuntu 20.04 LTS (Focal Fossa)
Released (5.30.0-9ubuntu0.2)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (5.26.1-6ubuntu0.5)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (5.22.1-9ubuntu0.9)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (5.18.2-2ubuntu1.7+esm3)
Ubuntu 12.04 ESM (Precise Pangolin)
Released (5.14.2-6ubuntu2.11)
Patches:
Upstream: https://github.com/perl/perl5/commit/897d1f7fd515b828e4b198d8b8bef76c6faf03ed