Your submission was sent successfully! Close

CVE-2019-6977

Published: 26 January 2019

gdImageColorMatch in gd_color_match.c in the GD Graphics Library (aka LibGD) 2.2.5, as used in the imagecolormatch function in PHP before 5.6.40, 7.x before 7.1.26, 7.2.x before 7.2.14, and 7.3.x before 7.3.1, has a heap-based buffer overflow. This can be exploited by an attacker who is able to trigger imagecolormatch calls with crafted image data.

Priority

Medium

CVSS 3 base score: 8.8

Status

Package Release Status
libgd2
Launchpad, Ubuntu, Debian
bionic
Released (2.2.5-4ubuntu0.3)
cosmic
Released (2.2.5-4ubuntu1.1)
precise Not vulnerable
(code not present)
trusty
Released (2.1.0-3ubuntu0.11)
upstream Needs triage

xenial
Released (2.1.1-4ubuntu0.16.04.11)
php5
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Not vulnerable
(uses system gd)
trusty Not vulnerable
(uses system gd)
upstream Needs triage

xenial Does not exist

php7.0
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream Needs triage

xenial Not vulnerable
(uses system gd)
php7.2
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(uses system gd)
cosmic Not vulnerable
(uses system gd)
precise Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

php7.3
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist