CVE-2019-20372

Published: 09 January 2020

NGINX before 1.17.7, with certain error_page configurations, allows HTTP request smuggling, as demonstrated by the ability of an attacker to read unauthorized web pages in environments where NGINX is being fronted by a load balancer.

Priority

Medium

CVSS 3 base score: 5.3

Status

Package Release Status
nginx
Launchpad, Ubuntu, Debian
Upstream
Released (1.17.7)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.17.7-0ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1.14.0-0ubuntu1.7)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (1.10.3-0ubuntu0.16.04.5)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (1.4.6-1ubuntu3.9+esm1)
Patches:
Upstream: https://github.com/nginx/nginx/commit/c1be55f97211d38b69ac0c2027e6812ab8b1b94e