CVE-2019-18397

Published: 07 November 2019

A buffer overflow in the fribidi_get_par_embedding_levels_ex() function in lib/fribidi-bidi.c of GNU FriBidi through 1.0.7 allows an attacker to cause a denial of service or possibly execute arbitrary code by delivering crafted text content to a user, when this content is then rendered by an application that uses FriBidi for text layout calculations. Examples include any GNOME or GTK+ based application that uses Pango for text layout, as this internally uses FriBidi for bidirectional text layout. For example, the attacker can construct a crafted text file to be opened in GEdit, or a crafted IRC message to be viewed in HexChat.

Priority

Medium

CVSS 3 base score: 7.8

Status

Package Release Status
fribidi
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.0.7-1.1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(0.19.7-2)
Ubuntu 16.04 LTS (Xenial Xerus) Not vulnerable
(0.19.7-1)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(0.19.6-1)
Ubuntu 12.04 ESM (Precise Pangolin) Not vulnerable
(0.19.2-1)
Patches:
Upstream: https://github.com/fribidi/fribidi/commit/034c6e9a1d296286305f4cfd1e0072b879f52568