Published: 24 September 2019

pam-python before 1.0.7-1 has an issue in regard to the default environment variable handling of Python, which could allow for local root escalation in certain PAM setups.

From the Ubuntu security team

Malte Kraus discovered that Pam-python mishandled certain environment variables. A local attacker could potentially use this vulnerability to execute programs as root.



CVSS 3 base score: 7.8


Package Release Status
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1.0.6-1.1+deb10u1build0.18.04.1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (1.0.4-1.1+deb8u1build0.16.04.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist