CVE-2019-14559

Published: 31 December 2019

Uncontrolled resource consumption in EDK II may allow an unauthenticated user to potentially enable denial of service via network access.

Priority

Low

CVSS 3 base score: 7.5

Status

Package Release Status
edk2
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(2020.05-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(0~20191122.bd85bf54-2ubuntu3)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (0~20180205.c0d9813c-2ubuntu0.2)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (0~20160408.ffea0a2c-2ubuntu0.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Ubuntu 12.04 ESM (Precise Pangolin) Does not exist

Patches:
Upstream: https://github.com/tianocore/edk2/commit/578bcdc2605e3438b9cbdac4e68339f90f5bf8af (bug 1610)
Upstream: https://github.com/tianocore/edk2/commit/1d3215fd24f47eaa4877542a59b4bbf5afc0cfe8 (bug 2031)
Upstream: https://github.com/tianocore/edk2/commit/65c73df44c61235ede84c5aa1d2eab6650844966 (bug 2032)
Upstream: https://github.com/tianocore/edk2/commit/9c20342eed70ec99ec50cd73cb81804299f05403 (bug 2174)
Upstream: https://github.com/tianocore/edk2/commit/4deef2d865efdc61d1a53ad7bd48f9dd42560b45 (bug 2655)