CVE-2019-12900

Published: 19 June 2019

BZ2_decompress in decompress.c in bzip2 through 1.0.6 has an out-of-bounds write when there are many selectors.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
bzip2
Launchpad, Ubuntu, Debian
Upstream
Released (1.0.7)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1.0.6-8.1ubuntu0.2)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (1.0.6-8ubuntu0.2)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (1.0.6-5ubuntu0.1~esm2)
Patches:
Upstream: https://gitlab.com/federicomenaquintero/bzip2/commit/74de1e2e6ffc9d51ef9824db71a8ffee5962cdbc
clamav
Launchpad, Ubuntu, Debian
Upstream
Released (0.101.4)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (0.101.4+dfsg-0ubuntu0.18.04.1)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (0.101.4+dfsg-0ubuntu0.16.04.1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (0.101.4+dfsg-0ubuntu0.14.04.1+esm1)