CVE-2019-10166

Published: 20 June 2019

It was discovered that libvirtd, versions 4.x.x before 4.10.1 and 5.x.x before 5.4.1, would permit readonly clients to use the virDomainManagedSaveDefineXML() API, which would permit them to modify managed save state files. If a managed save had already been created by a privileged user, a local attacker could modify this file such that libvirtd would execute an arbitrary program when the domain was resumed.

Priority

Medium

CVSS 3 base score: 7.8

Status

Package Release Status
libvirt
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 18.04 LTS (Bionic Beaver)
Released (4.0.0-1ubuntu8.12)
Ubuntu 16.04 LTS (Xenial Xerus) Not vulnerable
(code not present)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(code not present)
Patches:
Upstream: https://libvirt.org/git/?p=libvirt.git;a=commit;h=db0b78457f183e4c7ac45bc94de86044a1e2056a (5.4)
Upstream: http://libvirt.org/git/?p=libvirt.git;a=commit;h=a064d492272bcb0029b140ec4e18fce1ac0ec5b2 (5.0)
Upstream: http://libvirt.org/git/?p=libvirt.git;a=commit;h=00e673c93fc3d0cfed274cc7a1ec2c52260c8262 (4.6)
Upstream: http://libvirt.org/git/?p=libvirt.git;a=commit;h=d9a1f3debad411756f53ab8ab81e44ab0bb50e0a (4.1)