CVE-2018-6913

Published: 14 April 2018

Heap-based buffer overflow in the pack function in Perl before 5.26.2 allows context-dependent attackers to execute arbitrary code via a large item count.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
perl
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 16.04 ESM (Xenial Xerus)
Released (5.22.1-9ubuntu0.3)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (5.18.2-2ubuntu1.4)
Patches:
Upstream: https://perl5.git.perl.org/perl.git/commitdiff/a9d5c6e11891b48be06d4e06eeed18642bc98527 (5.24)
Upstream: https://perl5.git.perl.org/perl.git/commitdiff/0fcf83230df5f8c52602ae22fde57c7ea885534d (5.26)