Your submission was sent successfully! Close

CVE-2018-5390

Published: 6 August 2018

Linux kernel versions 4.9+ can be forced to make very expensive calls to tcp_collapse_ofo_queue() and tcp_prune_ofo_queue() for every incoming packet which can lead to a denial of service.

From the Ubuntu Security Team

Juha-Matti Tilli discovered that the TCP implementation in the Linux kernel performed algorithmically expensive operations in some situations when handling incoming packets. A remote attacker could use this to cause a denial of service.

Notes

AuthorNote
tyhicks
Known as "SegmentSmack"
Priority

High

CVSS 3 base score: 7.5

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-30.32)
cosmic Not vulnerable
(4.17.0-7.8)
precise
Released (3.2.0-135.181)
trusty
Released (3.13.0-155.205)
upstream
Released (4.18~rc7)
xenial
Released (4.4.0-133.159)
Patches:
Introduced by

36a6503feddadbbad415fb3891e80f94c10a9b21

Fixed by 72cd43ba64fc172a443410ce01645895850844c8
Introduced by

1da177e4c3f41524e886b7f1b8a0c1fc7321cac2

Fixed by f4a3313d8e2ca9fd8d8f45e40a2903ba782607e7
Introduced by

1da177e4c3f41524e886b7f1b8a0c1fc7321cac2

Fixed by 3d4bf93ac12003f9b8e1e2de37fe27983deebdcf
linux-aws
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1017.17)
cosmic Not vulnerable
(4.15.0-1020.20)
precise Does not exist

trusty
Released (4.4.0-1027.30)
upstream
Released (4.18~rc7)
xenial
Released (4.4.0-1065.75)
linux-azure
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1019.19)
cosmic Not vulnerable
(4.15.0-1023.24)
precise Does not exist

trusty Not vulnerable
(4.15.0-1023.24~14.04.1)
upstream
Released (4.18~rc7)
xenial
Released (4.15.0-1019.19~16.04.1)
linux-azure-edge
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.18.0-1004.4~18.04.1)
cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.18~rc7)
xenial
Released (4.15.0-1019.19)
linux-euclid
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.18~rc7)
xenial
Released (4.4.0-9029.31)
linux-flo
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
upstream
Released (4.18~rc7)
xenial Ignored
(abandoned)
linux-gcp
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1015.15)
cosmic Not vulnerable
(4.15.0-1018.19)
precise Does not exist

trusty Does not exist

upstream
Released (4.18~rc7)
xenial
Released (4.15.0-1015.15~16.04.1)
linux-gke
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.18~rc7)
xenial Ignored
(end-of-life)
linux-goldfish
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
upstream
Released (4.18~rc7)
xenial Ignored
(end-of-life)
linux-grouper
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
upstream
Released (4.18~rc7)
xenial Does not exist

linux-hwe
Launchpad, Ubuntu, Debian
bionic Not vulnerable

cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.18~rc7)
xenial
Released (4.15.0-30.32~16.04.1)
linux-hwe-edge
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.18.0-11.12~18.04.1)
cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.18~rc7)
xenial
Released (4.15.0-30.32~16.04.1)
linux-kvm
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1017.17)
cosmic Not vulnerable
(4.15.0-1020.20)
precise Does not exist

trusty Does not exist

upstream
Released (4.18~rc7)
xenial
Released (4.4.0-1031.37)
linux-lts-trusty
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise
Released (3.13.0-155.206~precise1)
trusty Does not exist

upstream
Released (4.18~rc7)
xenial Does not exist

linux-lts-utopic
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [out of standard support])
upstream
Released (4.18~rc7)
xenial Does not exist

linux-lts-vivid
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [out of standard support])
upstream
Released (4.18~rc7)
xenial Does not exist

linux-lts-wily
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [out of standard support])
upstream
Released (4.18~rc7)
xenial Does not exist

linux-lts-xenial
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty
Released (4.4.0-133.159~14.04.1)
upstream
Released (4.18~rc7)
xenial Does not exist

linux-maguro
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
upstream
Released (4.18~rc7)
xenial Does not exist

linux-mako
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
upstream
Released (4.18~rc7)
xenial Ignored
(abandoned)
linux-manta
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
upstream
Released (4.18~rc7)
xenial Does not exist

linux-oem
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1013.16)
cosmic Not vulnerable
(4.15.0-1017.20)
precise Does not exist

trusty Does not exist

upstream
Released (4.18~rc7)
xenial Ignored
(was needed now end-of-life)
linux-raspi2
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1018.19)
cosmic Not vulnerable
(4.15.0-1021.23)
precise Does not exist

trusty Does not exist

upstream
Released (4.18~rc7)
xenial
Released (4.4.0-1094.102)
linux-snapdragon
Launchpad, Ubuntu, Debian
bionic Not vulnerable

cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.18~rc7)
xenial
Released (4.4.0-1098.103)