Your submission was sent successfully! Close

CVE-2018-4200

Published: 7 May 2018

An issue was discovered in certain Apple products. iOS before 11.3.1 is affected. Safari before 11.1 is affected. iCloud before 7.5 on Windows is affected. iTunes before 12.7.5 on Windows is affected. tvOS before 11.4 is affected. The issue involves the "WebKit" component. It allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site that triggers a WebCore::jsElementScrollHeightGetter use-after-free.

Priority

Medium

CVSS 3 base score: 8.8

Status

Package Release Status
qtwebkit
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

eoan Ignored
(reached end-of-life)
focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

qtwebkit-opensource-src
Launchpad, Ubuntu, Debian
artful Ignored
(reached end-of-life)
bionic Needs triage

cosmic Ignored
(reached end-of-life)
disco Ignored
(reached end-of-life)
eoan Ignored
(reached end-of-life)
focal Needs triage

groovy Ignored
(reached end-of-life)
hirsute Ignored
(reached end-of-life)
impish Needs triage

jammy Needs triage

precise Does not exist

trusty Does not exist
(trusty was needs-triage)
upstream Needs triage

xenial Needs triage

qtwebkit-source
Launchpad, Ubuntu, Debian
artful Ignored
(reached end-of-life)
bionic Needs triage

cosmic Ignored
(reached end-of-life)
disco Ignored
(reached end-of-life)
eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Does not exist
(trusty was needs-triage)
upstream Needs triage

xenial Ignored
(end of standard support, was needs-triage)
webkit2gtk
Launchpad, Ubuntu, Debian
artful
Released (2.20.2-0ubuntu0.17.10.1)
bionic
Released (2.20.2-0ubuntu0.18.04.1)
cosmic Not vulnerable
(2.20.2-1)
disco Not vulnerable
(2.20.2-1)
eoan Not vulnerable
(2.20.2-1)
focal Not vulnerable
(2.20.2-1)
groovy Not vulnerable
(2.20.2-1)
hirsute Not vulnerable
(2.20.2-1)
impish Not vulnerable
(2.20.2-1)
jammy Not vulnerable
(2.20.2-1)
precise Does not exist

trusty Does not exist

upstream
Released (2.20.2)
xenial
Released (2.20.2-0ubuntu0.16.04.1)
webkitgtk
Launchpad, Ubuntu, Debian
artful Ignored
(reached end-of-life)
bionic Needs triage

cosmic Ignored
(reached end-of-life)
disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Does not exist
(trusty was needs-triage)
upstream Needs triage

xenial Ignored
(end of standard support, was needs-triage)

Notes

AuthorNote
jdstrand
webkit receives limited support. For details, see
https://wiki.ubuntu.com/SecurityTeam/FAQ#webkit
webkit in Ubuntu uses the JavaScriptCore (JSC) engine, not V8

References

Bugs