CVE-2018-20748

Published: 30 January 2019

LibVNC before 0.9.12 contains multiple heap out-of-bounds write vulnerabilities in libvncclient/rfbproto.c. The fix for CVE-2018-20019 was incomplete.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
italc
Launchpad, Ubuntu, Debian
Upstream
Released (1:3.0.3+dfsg1-1+deb9u1, 1:2.0.2+dfsg1-2+deb8u1)
Ubuntu 21.10 (Impish Indri) Does not exist

Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver)
Released (1:3.0.3+dfsg1-3ubuntu0.1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (1:2.0.2+dfsg1-4ubuntu0.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
libvncserver
Launchpad, Ubuntu, Debian
Upstream
Released (0.9.11+dfsg-1.3)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(0.9.11+dfsg-1.3)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(0.9.11+dfsg-1.3)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(0.9.11+dfsg-1.3)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (0.9.11+dfsg-1ubuntu1.1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (0.9.10+dfsg-3ubuntu0.16.04.3)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [0.9.9+dfsg-1ubuntu1.4])
Patches:
Upstream: https://github.com/LibVNC/libvncserver/commit/c5ba3fee85a7ecbbca1df5ffd46d32b92757bc2a
Upstream: https://github.com/LibVNC/libvncserver/commit/e34bcbb759ca5bef85809967a268fdf214c1ad2c
Upstream: https://github.com/LibVNC/libvncserver/commit/c2c4b81e6cb3b485fb1ec7ba9e7defeb889f6ba7
Upstream: https://github.com/LibVNC/libvncserver/commit/a64c3b37af9a6c8f8009d7516874b8d266b42bae
tightvnc
Launchpad, Ubuntu, Debian
Upstream
Released (1:1.3.9-6.5+deb8u1)
Ubuntu 21.10 (Impish Indri) Needs triage

Ubuntu 21.04 (Hirsute Hippo) Needs triage

Ubuntu 20.04 LTS (Focal Fossa) Needs triage

Ubuntu 18.04 LTS (Bionic Beaver) Needs triage

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needs-triage)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
x11vnc
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Not vulnerable
(uses shared libvnc)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(uses shared libvnc)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(uses shared libvnc)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(uses shared libvnc)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(uses shared libvnc)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(uses shared libvnc)