Your submission was sent successfully! Close

CVE-2018-17182

Published: 19 September 2018

An issue was discovered in the Linux kernel through 4.18.8. The vmacache_flush_all function in mm/vmacache.c mishandles sequence number overflows. An attacker can trigger a use-after-free (and possibly gain privileges) via certain thread creation, map, unmap, invalidation, and dereference operations.

From the Ubuntu security team

Jann Horn discovered that the vmacache subsystem did not properly handle sequence number overflows, leading to a use-after-free vulnerability. A local attacker could use this to cause a denial of service (system crash) or execute arbitrary code.

Notes

AuthorNote
sbeattie
as of 2018-09-26, fixes for this issue are applied to all
kernels uploaded to RELEASE-proposed today. and should be released
around Monday, Oct 1, 2018.
Priority

High

CVSS 3 base score: 7.8

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-36.39)
cosmic Not vulnerable
(4.18.0-9.10)
precise Not vulnerable

trusty Not vulnerable

upstream
Released (4.19~rc4)
xenial
Released (4.4.0-137.163)
Patches:
Introduced by

6b4ebc3a9078c5b7b8c4cf495a0b1d2d0e0bfe7a

Fixed by 7a9cdebdcc17e426fb5287e4a82db1dfe86339b2
linux-aws
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1023.23)
cosmic Not vulnerable
(4.18.0-1002.3)
precise Does not exist

trusty
Released (4.4.0-1031.34)
upstream
Released (4.19~rc4)
xenial
Released (4.4.0-1069.79)
linux-azure
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1025.26)
cosmic Not vulnerable
(4.18.0-1003.3)
precise Does not exist

trusty
Released (4.15.0-1030.31~14.04.1)
upstream
Released (4.19~rc4)
xenial
Released (4.15.0-1025.26~16.04.1)
linux-azure-edge
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.18.0-1004.4~18.04.1)
cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc4)
xenial
Released (4.15.0-1025.26)
linux-euclid
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc4)
xenial Ignored
(was needed ESM criteria)
linux-flo
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
upstream
Released (4.19~rc4)
xenial Ignored
(abandoned)
linux-gcp
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1021.22)
cosmic Not vulnerable
(4.18.0-1002.3)
precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc4)
xenial
Released (4.15.0-1021.22~16.04.1)
linux-gke
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc4)
xenial Ignored
(end-of-life)
linux-goldfish
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
upstream
Released (4.19~rc4)
xenial Ignored
(end-of-life)
linux-grouper
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
upstream
Released (4.19~rc4)
xenial Does not exist

linux-hwe
Launchpad, Ubuntu, Debian
bionic Not vulnerable

cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc4)
xenial
Released (4.15.0-36.39~16.04.1)
linux-hwe-edge
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.18.0-11.12~18.04.1)
cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc4)
xenial
Released (4.15.0-36.39~16.04.1)
linux-kvm
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1023.23)
cosmic Not vulnerable
(4.18.0-1003.3)
precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc4)
xenial
Released (4.4.0-1035.41)
linux-lts-trusty
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Not vulnerable

trusty Does not exist

upstream
Released (4.19~rc4)
xenial Does not exist

linux-lts-utopic
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [out of standard support])
upstream
Released (4.19~rc4)
xenial Does not exist

linux-lts-vivid
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [out of standard support])
upstream
Released (4.19~rc4)
xenial Does not exist

linux-lts-wily
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [out of standard support])
upstream
Released (4.19~rc4)
xenial Does not exist

linux-lts-xenial
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty
Released (4.4.0-137.163~14.04.1)
upstream
Released (4.19~rc4)
xenial Does not exist

linux-maguro
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
upstream
Released (4.19~rc4)
xenial Does not exist

linux-mako
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
upstream
Released (4.19~rc4)
xenial Ignored
(abandoned)
linux-manta
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
upstream
Released (4.19~rc4)
xenial Does not exist

linux-oem
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1021.24)
cosmic Not vulnerable
(4.15.0-1021.24)
precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc4)
xenial Ignored
(was needed now end-of-life)
linux-raspi2
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1024.26)
cosmic Not vulnerable
(4.18.0-1005.7)
precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc4)
xenial
Released (4.4.0-1098.106)
linux-snapdragon
Launchpad, Ubuntu, Debian
bionic Not vulnerable

cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.19~rc4)
xenial
Released (4.4.0-1102.107)