Your submission was sent successfully! Close

CVE-2018-16585

Published: 06 September 2018

** DISPUTED ** An issue was discovered in Artifex Ghostscript before 9.24. The .setdistillerkeys PostScript command is accepted even though it is not intended for use during document processing (e.g., after the startup phase). This leads to memory corruption, allowing remote attackers able to supply crafted PostScript to crash the interpreter or possibly have unspecified other impact. Note: A reputable source believes that the CVE is potentially a duplicate of CVE-2018-15910 as explained in Red Hat bugzilla (https://bugzilla.redhat.com/show_bug.cgi?id=1626193).

Priority

Medium

CVSS 3 base score: 7.8

Status

Package Release Status
ghostscript
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(9.22~dfsg+1-0ubuntu1.1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (9.18~dfsg~0-0ubuntu2.9)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [9.10~dfsg-0ubuntu10.13])
Patches:
Upstream: http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=1497d65039885a52b598b137dd8622bd4672f9be
Upstream: http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=971472c83a345a16dac9f90f91258bb22dd77f22
Upstream: http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=bcef41ad72a16472a3003d357bf8d8680174ab85
Upstream: http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=c1a8dc52c0e320c41d04b6f32086622150962d61